Can't make a copy of project

Tried to ‘copy to workspace’ and it fails. This worked in the past. Console error:

Access to fetch at ‘https://api.draftbit.com/graphql’ from origin ‘https://build.draftbit.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

We’ll take a look right away. We’re pushing out a bunch of new stuff, so sorry you keep seeing issues like this crop up but we appreciate you reporting them!!

Still can’t copy my project. Same CORS error:

Access to fetch at ‘https://api.draftbit.com/graphql’ from origin ‘https://build.draftbit.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

1 Like

Hi William,

We’ve been diving into this issue a bit more and are having trouble replicating - a few questions for you that would help us diagnose further:

  • What browser are you using?
  • Do you have any browser extensions installed, such as adblock or similar?
  • What is the name of the app you’re trying to copy? This will help us look more closely at your situation specifically to get this bug resolved.

Thank you!

Chrome and Chromium
Chrome is pretty clean. Chromium might have some extensions but not ad blockers or popup blockers.

Tried with both projects.

1 Like

Hey William, sorry for the delay here. We’ve shipped some better error logging that should help us track down what exactly is going on here. When you have a chance, would you mind attempting to duplicate again? That should give us a bit more information.

Worked this time! BTW, it would help keep track of things if the duplicated project had an extra tag on the end, like OriginalName.duplicate

I spoke too soon. One simple project copied, but the more complex on did not.

Good suggestion! I’ll add that to our internal list of feature requests. And got it – we’ll dive into the logs and figure this one out.

Hi @William_Dunning - we’ve shipped one possible fix for this issue. Would you mind trying again when you get a chance?

So sorry. No luck.

So sorry there’s been so much back and forth on this! We’ll keep digging.