Get this image to cover the screen

Im new and Im following the tutorial but my screen did not come out properly. What might I be doing wrong?

Hello @Jessica_Christine, it is a bit difficult to say what could be wrong with simply that screenshot. You could add your screen Layout view, as there we could spot what might be different.

It though looks like settings of Image background or maybe ScreenContainer are wrong.

If that is result of tutorial, then check that your Layout looks about like this:

If it looks like that, then maybe easiest way is for you to view code of that screen, copy it and paste here. Fastest way to see which part of actual code might look weird, or differentiates from my tutorial outcome. :slight_smile:


they look the same to me but im new to this. ill try to find the code.

worked perfectly! thank everyone for their help.

1 Like

Hey @Jessica_Christine!
Let’s double-check a couple of things!
First off, click the Image Background component and open up the styles config panel on the right side by clicking the paintbrush in the top right. The panel should look like this;

Scroll down to the Size section and check if the width and height are set to 100%, if not set them to them both to 100% .

If the issue is still persisting, then there may be a styling issue in the screen container, follow the same steps above to check the Size, but instead of clicking the Image Background click the Screen Container.

To get the code of the current screen or the entire app, just click the icon highlighted in the red square in the topbar and a window should opening showing you the code and giving you the ability to copy the current screen’s code or download your entire app.

If you’re still having issues, reach out to us here and or via the chat bubble in the builder!


Great to hear you got it working Jessica :slight_smile:

Hi there, I am having the same issue… I have tried setting the width and height in the container and imagebackground to 100%, however the render does not change