Support React-navigation v5

Export currently rely on react-navigation 4, v5 support should be provided too

Hey Laurent — Yep! We have this on our roadmap and should update our entire nav stack in the next month or so.

Hey Laurent — Our navigation is now based on v5! Thanks!